Time Tracking Summaries don't appear in the Stopwatch

Contents

Summary

After clicking Start in the Stopwatch, the newly started Time Tracking Summary doesn’t appear in the Stopwatch. Other active Time Tracking Summaries also don’t appear in the Stopwatch.

The issue occurs when a custom field is created on the Time Tracking Summary object with the same API Name as a field in the Time Tracking managed package.

The resolution is to change the API Name of the field to a name that doesn’t match a field in the managed package.

Replication Steps

In the Stopwatch, do the following:

  1. Enter a value in the Account field.

  2. If desired, enter a value in the second Lookup field.

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  3. Click Start.

    image-20240620-135147.png

Expected Results

When Start is clicked, the new Time Tracking Summary appears in the Stopwatch below the New Time Tracking section. Depending on the page, the Account and second Lookup fields in the New Time Tracking section may be cleared out.

Actual Results

When Start is clicked, the new Time Tracking Summary doesn’t appear in the Stopwatch below the New Time Tracking section. Depending on the page, the Account and second Lookup fields in the New Time Tracking section may be cleared out.

Cause

The issue occurs when a custom field is created on the Time Tracking Summary object with the same API Name as a field in the Time Tracking managed package. For example, if a custom field with the API Name Account__c is created, the issue occurs because there is a field in the managed package named TTracking__Account__c. Because the API Names of the two fields match when ignoring the TTracking namespace, the issue occurs.

Resolution

The issue can be resolved by making sure that no custom fields on the Time Tracking Summary object have the same API Name as fields in the Time Tracking managed package. For example, if there is a custom field with the API Name Account__c, change the API Name of the Account__c field to a name that doesn’t match the API Name of any field in the managed package, such as Account2__c.

Identify the field that is causing the issue

You can identify the problem field in the user interface, as well as in the browser’s DevTools.

Identify the field in the user interface

When the Stopwatch loads, if the issue is encountered, the field name is displayed in an error message at the top of the page.

Identify the field using the browser’s DevTools

  1. In the Stopwatch, do the following:

    1. Populate the Account field.

    2. If desired, populate the second Lookup field.

    3. Click Start.

  2. Open your browser’s DevTools.

  3. In the Console tab in DevTools, find the Server Error error message, which specifies the field that is causing the issue. Look for “duplicate field selected”.

Future State

To be able to have custom fields with the same names as fields in the Time Tracking package, vote for this Idea on the Salesforce IdeaExchange.

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